Ubuntu, Eclipse 3.4 (Ganymede), and Subclipse 1.4.4 Issue

I recently downloaded and installed the latest version of Eclipse (3.4.0 aka Ganymede) and ran into some issues when trying to get Subclipse (plugin for subversion) up and running.

Initially I was getting the following error message when accessing Windows->Preferences->Team->SVN->SVN Interface dropdown:

JavaHL (JNI) Not Available

When attempting to view a repository via the "SVN Repository Exploring" perspective I got a different error message:

Unable to load default SVN client

I checked and made sure the proper libraries were installed. Note I include hardy-backports in my packages and the version I am installing is higher than the non-backports package:

sudo apt-get install libsvn-java

There is a libsvn-javahl available however it is listed as a "dummy" package.

The package was already there so the issue continues...

Solution

There were a number of ways to fix this issue. I chose to set the path to the JavaHL libraries via a command line argument. I accomplished this by setting my Launcher icon for Eclipse to use the command:

/path/to/eclipse -vmargs -Djava.library.path=/usr/lib/jni

An alternative solution is to set the LD_LIBRARY_PATH environment variable to point to the /usr/lib/jni.

Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

I've followed your topic and

I've followed your topic and solved my problem.

Now, Ive 2 problems.
1) performance: easyeclipse-php is faster than eclipsePDT in checkout with the same repository
2) eclipsePDT downloads around 12KB, and its counter points to 9%, then, "An internal SVN error"

who can help me?

Thank you

Hi

this worked fine for me. Thank you. I don't understand why it is such a problem to have it working after installing right away

Found the solution to the

Found the solution to the problem the version of subclipse i have installed requires subversion 1.5.x and javasvn 1.5.x so i added another source and it works now with an updated subversion package

I'm having problems getting

I'm having problems getting this to work on my ubuntu 8.0.4.1 box with both eclipse 3.3.2 and 3.4

i have libsvn-java installed and subversion and in my eclipse its a fresh install and i have subclipse installed but still it says JavaHL not available in the drop down and i've done -Djava.library.path=/usr/lib/jni in my eclipse.ini file any ideas ?

Same problem plus fix

I had the same problem as you and I think that the issue lies where eclipse does not update the java.library.path and does not see the JavaHL files.

Now what I did was the following;

- First, I got eclipse to tell me the error and it contains the line where it tells you the java.library.path in may case it was this

/usr/lib/jvm/java-6-sun-1.6.0.15/jre/lib/i386/client:/usr/lib/jvm

- To fix the error, I made a symlink of the these files: libsvnjavahl-1.so, libsvnjavahl-1.so.0, libsvnjavahl-1.so.0.0.0 to the directory above

The last two libsvnjavahl-1.so.* might be copies of the first one.

Thanks,
Jose

Try running the following

Try running the following command from the command line:

/path/to/eclipse -vmargs -Djava.library.path=/usr/lib/jni

Post new comment

The content of this field is kept private and will not be shown publicly.
By submitting this form, you accept the Mollom privacy policy.